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Introduction to This Guide 
 

Today you'll discover how to manage your masses and assign ministers using PDS Ministry Scheduler. 

Being able to set up a schedule is important, but we'll also go over how to print and email schedules, 

specify times when ministers are unable to serve, and group ministers to serve together. 

 

If you're new to the program, we'll talk about how to set up your minister records and schedules, along 

with some defaults and preferences. Before you know it, you'll be scheduling ministers like a pro! 

 

Let's start off with another introduction 

Paula Martin has been on staff at Saint Mary's Catholic Church for almost 5 years now. She was reluctant 

to use new software at first, but after a product demo, she sees that it eliminates a lot of manual work 

she's had to do. 

 

 
 

Paula has over 20 events and daily, weekend, and special masses. She's also responsible for tracking and 

scheduling 9 ministers and 6 volunteers. 

 

Anytime someone can't serve, Paula gets an email. Anytime someone thinks they can't serve but then 

finds out they can, Paula gets an email. Paula gets a lot of emails. 

 

Right now, she does her best to track all of this information in a bunch of different spreadsheets. 

Between those and her emails, it can get confusing. Paula looks forward to better organization and 

management of Saint Mary's masses and ministers. So let's begin. 

  



4 

Unit 1:  Setting Up PDS Ministry Scheduler 
 

Paula's eager to jump in and start working. But before she can add her schedules, she needs to think of 

how scheduling should work for each minister and each mass. 

 

By the end of this unit, you'll be able to: 

 Set the minster ID number options and maximum assignment options 

 Select the default scheduling options you want to use 

 Add your parish's special dates (like birthdays and appointments) as well as holidays to the 

calendar in PDS 

 Add the types of ministries your ministers serve 

 Establish your email settings and text message providers  
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 Get Started 

The first thing Paula has to do is start Ministry Scheduler. That's easy enough! Double-click the PDS 

Ministry Scheduler icon on the desktop. 

 

The very first time you open PDS, the License Registration Wizard displays. This helps you create a new 

database or convert your data from a prior version. 

 Set Initial Options 

At Saint Mary's, each minister has an ID number. Paula wants these to be same as the minister's ID in 

PDS. She can pick a number to start with in PDS and choose whether to assign these IDs automatically. 

Likewise, she can choose an ID number to start from for family records. 

 

Paula can set certain defaults and maximum values for her ministers and their assignments. For 

example, Saint Mary's doesn't allow a minister to have more than seven assignments in a single week, 

and there can only be up to 10 ministers in a single ministry. 

 

To set these options for your parish, on the File menu, click Setup > Initial Setup. 

 

We'll talk about the rest of the options a little later. 

 Set Up Your Calendar 

Paula wants holidays and special events to show up on her calendar. Seeing those can help her when 

scheduling minister assignments. At Saint Mary's, ministers don't have to serve on their birthday (unless 

they want to). This way, Paula can see in PDS when those birthdays occur. 

 

Before you start, make a list of important days you want to include. 

 

To set up special days and holidays 

1. On the File menu, click Setup > Special Days & Holidays. 

2. Click Automatic Setup for a New Year. 

3. Select Choose predefined dates, then select the type(s) of dates you want to show on your 

calendar. Click Add/OK. 

4. If you want to add special days like birthdays, click Insert Date. Enter the information for the 

special day, then click Save/OK. 

5. Click Close. 
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 Set Up Options Used for Scheduling 

Before Paula can schedule any masses, she has to set up the scheduling options. This improves the way 

the scheduling process works for Saint Mary's specific needs. 

 

It may take some time to fully understand how the options you choose affect who is scheduled at what 

time. But don't worry – you can always come back and change these options later. 

 

 
Figure 1-a. Scheduling options tabs 

 

Let's talk about these options. 

 

Cannot Serve Days 

The children's minister, Ana, can't serve on Mondays or Wednesdays because she works at Saint Mary's 

Catholic school those days. 

 

When Paula adds minister record, she can specify the days each minister are unavailable. If ministers 

absolutely cannot serve a particular day, even if it's a special mass, select the option to enforce the 

ministers' "Cannot Serve Days" for special masses. That way, ministers are never considered for 

scheduling on their selected days. 

 

For example, let's say All Saints Day is on a Wednesday. Saint Mary's has a special mass that day. If the 

option is enforced, Ana is not scheduled for this mass since she specified that she can't serve on 

Wednesdays. 

 

Normally, Saint Mary's school is closed when special masses occur, so Ana is available serve. And Ana 

has told Paula that she can always get a substitute if needed. So Paula decides not to enforce Cannot 

Serve Days for special masses. 
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Preferred Mass Settings 

After Paula adds minister records in PDS, she can specify certain masses that each minister prefers to 

serve. Debbie Stewart, the prayer minister, likes to serve at the regular 9:00 AM mass every Sunday. 

Let's look at some decisions Paula has to make around preferred masses. 

 

If the regular 9:00 AM mass falls on a holiday Sunday, it's considered a special mass. In Ministry 

Scheduler, a special mass replaces a regular mass. The question is, should Paula let Debbie serve at her 

preferred time, even if it's during a special mass? 
 

 If Paula wants to allow Debbie to serve no matter what, she can select Use a Preferred Mass for 

a Special Mass Replacement. 
 

 Otherwise, if Paula only wants Debbie to serve at 9:00 AM on regular mass days, she should 

clear this option. 

 

Debbie also likes to serve at the Christmas Midnight Mass. However, she indicated that she cannot serve 

after 8:00 PM. Should Paula let Debbie serve her preferred mass, even if it's at a time she can't serve? 
 

 If Debbie shouldn't serve during her Cannot Serve time, Paula can select Deny a Preferred Mass 

if it occurs during a Cannot Serve Time of Day. 
 

 Otherwise, if Debbie should serve her preferred mass no matter what time it occurs, Paula can 

clear this option. 

 

There are two options for managing preferred masses for ministers: 
 

 Assign mass #1, then mass #2, then mass #3. If Paula assigns ministers to preferred masses in 

this strict order, she can select Always Consider Ministers Preferred Masses in Original Order. 
 

 For week 1, assign Mass #1. For week 2, assign Mass #2. For week 3, assign Mass #3. If Paula 

wants to rotate ministers through the preferences like this, she should select Rotate Through 

Ministers Preferred Masses. 

 

Daily Mass/Max Assignments 

Paula can set the maximum number of times a minister can serve. This comes into play when the 

scheduler assigns ministers. Since daily masses may happen on one day or multiple days, Paula needs to 

determine how the scheduler views those masses. 

 

For example, Saint Mary celebrates a daily mass on Wednesdays and Thursdays. If Paula selects 

Consider Daily Mass and Ministers Max Assignments, Ministry Scheduler creates two entries and 

assigns one minister to both days. This shows up as two assignments, so the minister must have the 

capacity to serve two days per week and/or month.  

 

Otherwise, if Paula chooses not to consider these and clears the option, the scheduler creates only one 

entry for the mass. A minister is assigned to Wednesday, which actually represents both days. 
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Minister Names 

Paula can choose how minister names appear in the Scheduled Weeks list and whether the ministry 

abbreviation displays. She can also choose the order the ministers show up after she creates a schedule. 

 
Rename Unfilled 

Once Paula creates a schedule, there may be some positions that weren't assigned. This could be 

because no ministers were available for that ministry or time slot, or the minister's preferences 

prevented them from being assigned. 

 

 
Figure 1-b. One unfilled Eucharistic Minister position for Confession 

 
When no ministers are assigned to a position, it shows up on the schedule as <Unfilled Position>. 

However, you can customize this to anything you want or make it show up as a blank space. 

 
Determine Weeks 

The scheduler needs to know how St. Mary's views each "week" in a month. Here's what it affects:  

If the last day of the month is on a Saturday, how do you want to schedule for those days since mass 

scheduling starts on Monday and ends on Sunday? 

 

We recommend that you choose to consider Saturday as the last week of the previous month, and 

consider Sunday as the first week of the next month. 

 

However, if needed, Paula can consider both days as the first week of the next month or she can 

consider both days as the last week of the previous month. 

 

To set scheduling options 

1. On the File menu, click Setup > Scheduling Options. 

2. On each tab, select the options that meet your parish's needs. 

3. Click Save, then Close. 

 

Paula feels overwhelmed by the vast flexibility used in scheduling. You might be feeling the same way. 

Remember that you don't have to use every option just because it's there. Start by using only the basic 

options you need, then slowly add more options as you need them. 
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Here are some tips to ease the tension: 
 

 The more "open" your schedule is, the easier it is for ministers to be scheduled. If you select a 

bunch of options to restrict who can serve when, it's more difficult for ministers to be assigned. 
 

 It's usually better to start with a relatively closed scheduling process. Then you can open it up as 

needed for the church's needs or for each minister's needs. This also helps you get a better 

grasp when you're first learning how to use Ministry Scheduler. 
 

 Run a few practice schedules and test out different options. 

 

Think about all of your ministers and masses. Make a list of your ministers and what you think their 

Cannot Serve Days are. List any additional options for each minister that you can think of. 
 

(Minister Name) cannot serve (days, weeks, and/or times) 

 
_______________________________ cannot serve ___________________________________________ 

 Additional options: ______________________________________________________________ 

_______________________________ cannot serve ___________________________________________ 

 Additional options: ______________________________________________________________ 

_______________________________ cannot serve ___________________________________________ 

 Additional options: ______________________________________________________________ 

 

Once you get back from training, plan to discuss these options with each minister. After that, you can 

decide how "open" you want your scheduling process to be, and how easy you want it to be for your 

ministers to be assigned. 

 

 Now it's your turn 

1. Paula scheduled the masses for next week. On Monday, she gets a call from Ana. She's 

scheduled for the special Ash Wednesday mass, but she's not able to serve on Wednesdays. 

Paula checks Ana's Cannot Serve Days, and Wednesday is selected, as it should be. 

Why is Ana scheduled on her Cannot Serve Day? How can Paula correct this? 

 

______________________________________________________________________________

______________________________________________________________________________ 
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 Add and Combine Keywords 

Before Paula came on board, Jim handled all the data. He let ministers fill out their own information, 

and it was all over the place. Nothing was consistent. Paula reviews how she can use keywords to 

remove these and avoid future discrepancies. 

 

Keywords represent data used repeatedly in Ministry Scheduler. This simplifies data entry and 

eliminates the possibility of spelling errors and inconsistent usage. 

 

We'll talk about some of these keywords along the way, but to get started, Paula needs to add the 

ministry names used at Saint Mary's, any classes or groups, and any reasons a minister might be away 

and unable to serve. 

 

Paula can list her ministries right off hand (outreach, hospitality, youth, and so on), but she's not sure 

about "class/group". Well, this can be anything you need it to be. If you use some kind of classification 

or grouping to identify your ministers, you can enter those "tags" to use on minister records. 

 

Saint Mary's music ministry has two bands that several ministers and volunteers sing or play for. In the 

Class/Group keyword list, Paula enters "Rock of Faith" (the group that leads the congregation in singing 

hymns in a contemporary style) and "Traditional Cantors" (who chant in Latin during mass with organ 

music in the background). 

 

When she adds those ministers' records, she can tag them as being in one or both of the bands. She can 

then use this information in reports, which we'll see how to do in Unit 7. 

 

What ministries does your parish have? 

 

_________________________________________       _________________________________________ 

_________________________________________       _________________________________________ 

_________________________________________       _________________________________________ 

_________________________________________       _________________________________________ 

 

Do you have any other groups? Are those groups within your ministries or separate from them? 

 

_________________________________________       _________________________________________ 

_________________________________________       _________________________________________ 

_________________________________________       _________________________________________ 
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To add a keyword 

1. On the File menu, click Keywords. 

2. Select a keyword category. 

3. Click Insert. 

4. Enter a name for the keyword. To move to the next field, press Tab or Enter on your keyboard. 

5. Click Save/OK > Close. 

 

  Warning 

If you change a keyword, that keyword changes on any records that use it. 

For example, in the Email Description Names keyword list, you change the keyword 
"Home" to "Personal". All records that had the email description keyword "Home" now 
display "Personal". 

 

 

As Paula adds keywords, she realizes some of them are very similar. In her Ministry Status Names list, 

she has "Actively Involved" and "Active Member". 

 

Instead of changing or deleting a keyword, Paula likes the idea of combining them. This way, she can 

quickly replace one keyword with the other. 

 

To combine keywords 

1. On the File menu, click Keywords. 

2. Select the keyword category of the keywords you want to combine. 

3. Click Combine. 

4. On the left, select the keyword you want to change on existing records. (This is the one you 

don't want to see anymore.) 

5. On the right, select the keyword it should be changed to on existing records. (This is the one you 

want to keep in the list.) 

6. Click Add to List of Changes Below. 

7. When you're ready, click Combine/OK. 
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 Now it's your turn 

Paula adds a new phone description of "Work" in the Phone Description Names keyword list. On Ana's 

record, Paula selects Work and enters Ana's work number. Later, Paula decides to change the "Work" 

keyword to "Work Phone". 

 

1. What does Ana's record now show as the description for her work number? 

 

_____________________________________________________________ 

 

Paula pulls in the minister information from her old files. She notices that she has "Office Phone" and 

"Work Phone" keywords in PDS. On Ben's record, she had selected Office Phone as the description. 

Paula combines the "Office Phone" keyword with the "Work Phone" keyword as follows: 

 

 
 

2. What does Ben's record now show as the description for his work number? 

 

_____________________________________________________________ 

 

Paula then deletes the "Work Phone" keyword from the Phone Description Names keyword list. 

 

3. What shows on Ana and Ben's records beside their work numbers? 

 

_____________________________________________________________ 
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 Set Up Emailing and Text Messaging from PDS 

In a product demo, Paula heard that she can send emails and text messages from Ministry Scheduler. To 

do that, she needs to set up her email server and the cellular providers her ministers use. 

 

You can get information about your email server settings from your system admin or Internet provider. 

Contact the cellular provider for their server information. 

 

To set up your email server 

1. On the File menu, click Setup > Email & Text Setup. 

2. On the Email Server Setup tab, enter the technical information for connecting your email server. 

 Email Server (SMTP) – This is your Simple Mail Transfer Protocol. 

 Email Server Port – The default is 25. 

 Server Requires Authentication – Select this if you have to log in to your email server. Enter 

your email account name and password. Select which email server you use. 

 Server Limit Emails – Select this if your server restricts the number or size of incoming and 

outgoing email messages. 

 If an Error Occurs, Delay 30 Seconds and Retry Once – If your email server experiences an 

error, you can request that PDS try to resend after a 30-second delay. 

 Sending Emails from a Record – Select whether to open your default email program or the 

simple email dialog when sending an email within PDS. If you're OnDemand, we recommend 

the simple email option. 

3. When you're finished, click OK. 

 

To set up text providers 

1. On the File menu, click Setup > Email & Text Setup. 

2. On the Text Message Provider Setup tab, review the list of text providers. By default, the 

information for most providers displays. 

3. If you need to add one that's not in the list, click Insert and enter the information from the 

provider. 

4. If you want to add these to the Phone Type keyword list, select the check box. If selected, you 

can quickly select the Provider Type keyword when adding minister contact information. 

5. When you're finished, click Save. 
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Unit 2:  Adding Your Masses 
 

Now that Paula has some of the program options set, she can add her masses. Some occur daily or 

weekly, and some happen during special events once a year. 

 

At the end of this unit, you'll be able to: 

 Set the word your parish uses for masses 

 Define the 3 mass types and identify the differences between them 

 Add records for your masses so you can schedule them 

 Remove a mass from scheduling without deleting it 
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 Set a Word for Labels 

During the product demo, one of the things Paula was concerned about was how PDS used the word 

"mass" instead of what she's used to. Not to worry -- there's an option for that! 

 

You can change the word that displays in Ministry Scheduler to anything you want. The name you 

choose shows up in several locations, including buttons and fields. Since Saint Mary's uses the word 

"liturgy", Paula selects that term, then clicks through Ministry Scheduler to see where it shows up. 

 

 
Figure 2-a. Section labeled Liturgies instead of Masses 

 

 

To change the term 

1. On the File menu, click Setup > Mass Labels. 

2. Select the terms you want to use, or enter custom names to use. 

3. Click Save/OK, then click Close. 

 

For the purposes of this training manual, we'll use "masses". 

 

 Add a Mass 

Paula looks at her list of masses and notices she has a few different types that occur: 
 

 Every week at the same time on the same day 

 At the same time throughout the week 

 Only once a year for a holy day or special celebration 

 
Define Mass Types 

In PDS, these "types" are known as permanent, daily, and special masses. 

 

Let's review what each of those means. 
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A permanent mass occurs at the same time, on the same day, every week. Use this type for Saturday 

evening and Sunday masses. 

 

 
Figure 2-b. Example of a permanent mass 

 

A daily mass typically occurs at the same time on one or more days of the week. For example, Saint 

Mary's holds Confession at 4:30 every Tuesday, Friday, and Saturday. 

 

 
Figure 2-c. Example of a daily mass 

 

A special mass is a holy day or celebration that has a specific date and typically does not recur within a 

calendar year. For example, Saint Mary's celebrates a special Christmas Midnight Mass. 

 

 
Figure 2-d. Example of a special mass 
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To add a permanent mass 

1. On the Information tab, click Masses. 

2. At the top, click Add Mass. 

3. Select the Permanent mass type. 

4. Select the day of the week when the mass occurs. 

5. If the mass only occurs on certain weeks of the month, clear the check boxes of the weeks the 

mass does not occur. 

6. Enter the time when the mass occurs. 

7. Enter a name or select to use the day and time as the mass name. 

8. Click Save. 

 

To add a daily mass 

1. On the Information tab, click Masses. 

2. At the top, click Add Mass. 

3. Select the Daily mass type. 

4. Select the day(s) the mass is celebrated. 

5. Enter the time when the mass occurs. 

6. Enter a name or select to use the day and time as the mass name. 

7. Click Save. 

 

To add a special mass 

1. On the Information tab, click Masses. 

2. At the top, click Add Mass. 

3. Select the Special mass type. 

4. Enter the date of the mass. Click Special Date to select a date from your calendar. 

5. To add this special mass for following years, select Automatic set the date every year. 

6. If this mass occurs during a regularly scheduled mass and it needs to replace that one, select the 

scheduled mass in the Replaces drop-down list. 

7. Based on your needs, select or clear Consider the Only Schedule Preferred Masses for 

Ministers Assigned to this Mass. If selected, ministers who are only scheduled for preferred 

masses are not considered for scheduling during this mass. If cleared, all ministers (including 
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those who only want to be scheduled for their preferred masses) are considered for an 

assignment during scheduling. 

8. Enter the time when the mass occurs. 

9. Enter a name or select to use the day and time as the mass name. 

10. Click Save. 

 

Now, you need to add ministries for each mass. This lets the scheduler know which ministers should be 

assigned to this mass. 

 

To add ministries for a mass 

1. Locate the mass, and go to the Primary Information window. 

2. Below the Mass Ministry grid, click Insert. 

3. Select the ministry, and enter the number of ministers needed for this mass. 

4. If needed, select a class/group for this ministry. 

5. Click Save. 

 

 

 Now it's your turn 

1. What information do you need when adding a mass? 

______________________________________________________________________________

______________________________________________________________________________ 

 

2. Add a record for Saint Mary's Christmas Midnight Mass. It requires 4 Altar Servers, 2 Eucharistic 

Ministers, and 2 Lectors. (You can see how the record looks in the Answers section at the end of 

this manual. But don't peek until you try it!) 
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 Remove a Mass from Scheduling 

Paula added a Special Sunrise Easter Mass at 6:30 AM. This conflicts with the regular Sunday morning 

mass at 7:00. For Easter Sunday, she can mark the regular mass inactive so it isn't included in the 

scheduling process. Ministers are not assigned to inactive masses. 

 

  Warning 

Never delete a mass record to prevent it from being scheduled. 

When you delete a mass, you break the association between the minister preferences and 
the now non-existent mass. So the preferences in all the ministers' records are also 
deleted. By inactivating it, you keep that link. 

 

 

To mark a mass inactivate 

1. On the Information tab, click Masses. 

2. Locate the mass you want to remove from the schedule. 

3. Select the Inactive check box. 

4. Click Save. 

 

 

When she's ready for the regular Sunday mass to be considered for scheduling, Paula can reactivate it. 

 

To reactivate a mass in the schedule 

1. On the Information tab, click Masses. 

2. Locate the mass you want to restore and include in the schedule. 

3. Clear the Inactive check box. 

4. Click Save. 
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Unit 3:  Adding Records for Your Ministers 
 

In different spreadsheets on her computer, Paula has lists of ministers and which days and times they 

can and cannot serve, which services they like to serve, vacation times and days off, and other details. 

She's so ready to get this data in one place, organized in a way that she can efficiently manage them. 

 

By the end of this unit, you'll know how to: 

 Create a record for a minister and add his/her contact information 

 Set preferences the minister has for types of masses, ministry, and times of day 

 Select options to determine how ministers should be scheduled 
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 Add a Minister 

In Ministry Scheduler, each minister has a record where you can track all of their information, including: 

 Contact information 

 Interactions through letters, calls, or visits 

 Assignments 

 Days the minister can't serve 

 Masses the minister prefers to serve 

 

To add a new minister 

1. On the Information tab, click Ministers. 

2. At the top-right, click Add Minister. 

3. Make sure the minister doesn't already have a record. 

4. Click Add New Minister. 

5. Enter the minister's contact information. 

6. Click Save. 

 

We'll talk about the other places you can enter minister information in just a minute. 

 

 Now it's your turn 

1. Add Steve Redmond as a minister. Fill in the following information: 

 Address: 455 Pleasant Way Florence, SC 29501 

 Home phone number: (843) 555-4324 

 Cell phone number: (843) 555-7897 

 Email address: s.redmond@parishdata.com 

 

We'll include more information about Steve throughout this unit. 

 

 

Copy a Minister's Record 

A few ministers share some of the same information, like Estelle (the family minister) and Steve (the 

outreach minister) who are married. Instead of entering the same data for each person, Paula can copy 

it from an existing minister's record to add a new one. 

 

Hmm, this feels like déjà vu… Paula remembers seeing something about copying minister data when she 

was setting up PDS. Good memory! Let's go back to those settings on the File menu. 
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To set which minister data to copy 

1. On the File menu, click Setup > Minister Data to Copy. 

2. Select the data field(s) you want to copy from an existing minister record to a new one. 

3. Click Save/OK. 

 

Once you set the data to copy from one record to another, you're ready to add the minister. 

 

To copy an existing minister's data to a new minister record 

1. On the Information tab, click Ministers. 

2. At the top-right, click Add Minister. 

3. Make sure the minister doesn't already have a record. 

4. In the list, find the minister record you want to copy to a new one. 

5. Click Use This Minister Info. A new record is added with the selected data copied from the 

existing minister. 

6. Enter any additional information about the new minister. 

7. Click Save. 

 

Pull In a Member from PDS Office 

If you work in any of the PDS Office programs, you can pull in an existing record to add as a minister. 

 

To add a minister from a PDS Office program 

1. On the Information tab, click Ministers. 

2. At the top-right, click Add Minister. 

3. Make sure the minister doesn't already have a record in Ministry Scheduler. 

4. Click Show PDS Office Members. 

5. The first time you set this up, browse to the location where your PDS Office data files live. For 

example, "C:\PDS\Office\Data". 

6. In the list, locate and select the PDS Office member you want to add to Ministry Scheduler. 

7. Click Use This Member Info. 

8. Select which member information you want to include in the new minister record, and click OK. 

9. Enter any additional information you want on the new record. 

10. Click Save. 
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 Insert Special Characters and Symbols 

Manuel Díaz is the minister who organizes music for Rock of Faith and the Traditional Cantors groups. 

Paula has known Manny since he was 4-year-old, and is good friends with his parents. He has always had 

a God-given gift for music. 

 

She wants to enter his last name with the proper accent mark over the 'i'. Usually when she needs an 

accented character, she opens a new document or searches the web for it. Instead of trying to copy and 

paste it, there's a quick, convenient way to add it within PDS. 

 

Right-click in any name field, and click Insert Symbol. Click a character to insert it in the field. 

 

 
Figure 3-a. Symbols in the right-click menu 

 

Do any of your minister or mass names have special characters? If so, write them here. 

 

______________________________________________________________________ 

______________________________________________________________________ 

______________________________________________________________________ 

______________________________________________________________________ 

______________________________________________________________________ 
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 Determine How Ministers Are Scheduled 

We're going to talk about scheduling in the next unit, but there are some options on the minister's 

record related to scheduling. 

 

Let's look at how Paula can edit a minister's record to determine how they are scheduled. 

 

Remove Ministers from Scheduling 

Sometimes, things come up that no one can control. Last year, Joan Byars (the administrative assistant), 

lost her husband suddenly to a heart attack. Joan had so much to do in such a short time. 

 

In cases like this, Paula needs to make sure the minister isn't assigned to serve. 

 

To remove a minister from scheduling 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Assignment Options. 

4. Select Do Not Schedule. 

5. Click Save. 

 

When the minister comes back, Paula can easily clear the Do Not Schedule option. 

 

But wait… Paula pauses, remembering that there's an Inactive option on minister records. So how is this 

different from marking the minister Inactive? Inactivation is a more permanent option, whereas the Do 

Not Schedule option is temporary. 

 

Let's look at some examples of when to use each option. 

 

 Now it's your turn 

What should Paula do in the following situations? 

 

1. Steve is going out of the country for a mission trip, but can't give details due to the sensitive 

nature of the mission. Paula isn't sure when he'll be back. 
 

o Mark Steve's record as inactive o Select the Do Not Schedule option  

on Steve's record 
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2. Evan Wagner, a volunteer, is moving to another state and will no longer be able to serve at Saint 

Mary's. Paula wants to keep his information. 
 

o Mark Evan as inactive o Do Not Schedule Evan 

 

3. Debbie's 98-year-old mother is very sick and has been moved to hospice care. Debbie needs to 

take some time off to spend with her mother. 
 

o Mark Debbie as inactive o Do Not Schedule Debbie

 

 

 

Rotate Ministers Between Masses 

You may prefer that ministers serve a different mass from the last one they served. 

 

To rotate a minister between masses 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Assignment Options. 

4. Select Serve Different Mass from Last Served Mass. 

5. Click Save. 

 

Restrict How Many Times Ministers Can Serve 

You may want to restrict the number of times a minister can serve during a week or month.  

 

To set the number of times a minister can serve 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Assignment Options. 

4. Enter the number of assignments a minister can serve each week. These number options come 

from the Max Number Assignments Per Week setting in the Initial Setup window. 

5. If you only want them to serve a certain number of times per month, select that option and 

enter the number. These options come from the Max Number Assignments Per Month setting. 

6. If you don't want the minister to serve the week after they last served, select Do Not Schedule 

Consecutive Weeks. 

7. Click Save. 

 

We'll talk about the Direct Assignments section on this window in a little while.



26 

 Set the Types of Services Ministers Can Serve at Certain Times 

Paula added Steve as a minister a little while ago, but there's other information still missing. Paula clicks 

through the links in the left navigation pane. She comes across the Type & Time Availability window. 

 

Most ministers generally don't serve after midnight. But there are times like the Christmas Midnight 

Mass where ministers would be willing to serve. 

 

You can set a minister's time availability for each type of mass here. 

 

To set a minister's service types 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Type & Time Availability. 

4. By default, the Available to serve option is selected for all mass types. Clear this option if the 

minister is unavailable to serve a certain mass type. 

5. If a minister can serve a mass but is unavailable at certain times, you can enter them in the grid. 

To quickly enter times, click Quick Enter Type & Time Availability and follow these steps: 

 Determine when morning, afternoon, evening, and night start, and click Apply. 

 In the grid, select the time periods the minister is unable to serve. 

 Click Yes to use this setup for the current minister. 

6. Click Save. 
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 Set Dates When Ministers Can and Cannot Serve 

Remember how Ana can't serve Mondays or Wednesdays? Here's where Paula actually sets those 

Cannot Serve Days. She can also set certain weeks ministers are unable to serve and add dates when 

ministers will be away. 

 

To set date restrictions for a minister 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Date Restrictions. 

4. If needed, select any days of the week the minister cannot serve. 

5. If needed, enter the dates and reason the minister will be away. 

6. If needed, select any weeks the minister cannot serve. If the minister can only serve odd or even 

weeks of the year, select that option. 

7. Click Save. 

 

 

 Now it's your turn 

1. Steve is going to be away on a mission trip (not affiliated with Saint Mary's) from December 5 

through 10 of this year. Where does Paula need to set these dates Steve will be away? 

 

______________________________________________________________________________

______________________________________________________________________________ 

 

2. On Steve's record, add the dates he will be away. 
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 Set Who a Minister Can Serve With 

Paula can set options for each ministry the minister serves. 

 

Also Assign to Ministry 

She can select a ministry that the minister can perform during the same mass. For example, Steve is 

primarily the outreach minister, but he can perform lector duties during the same mass. So, on Steve's 

record under the Outreach ministry, Paula marks that Steve can serve as a lector for this assignment. 

 

Class/Group 

Paula sees the Class/Group field. This seems familiar… oh right, that's what we added keywords for 

earlier! She clicks the drop-down arrow, and sure enough, there are the two music groups Paula added. 

When scheduling, Paula can use this field to assign only servers of a particular class or group to a mass. 

 

Family Mode 

Since Steve and Estelle are married, they're considered a family. Paula can decide how family members 

serve. For each ministry, family members can serve together, or they can alternate so only one member 

serves in the ministry at a time. 

 

Alternatively, you can use the Serve With list, which we'll see in a moment. If you use this list, set Family 

Mode to None for best results. 

 

Number of Ministers Serving 

If Paula always wants multiple family members to be scheduled together, she can create a single record 

that represents the couple or family. For example, Paula can schedule "Steve & Estelle" or "The 

Redmond Family" instead of each one individually. 

 

In order for the scheduler to know that a record represents multiple people, you can enter the number 

of ministers serving on the record. Up to seven people can serve together per ministry. 

 

Serve With List 

Paula knows that Ana and Ben like serving together. However, they're not a family (not yet anyway… 

Paula expects an engagement announcement any day now). So she can't group them as a family, but she 

can let the scheduler know to assign them together when possible. 

 

When you add someone to a minister's Serve With list, you're prompted to add that minister to the 

other person's Serve With list as well. Convenient! 

 

Substitute List 

When Steve leaves for his mission trip, volunteer Perry Caldwell has agreed to take on his assignments. 

Paula can set Perry up as a substitute on Steve's record. 
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To set serving options for a minister 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Serving Options. 

4. On each ministry tab, select serving options for that ministry. 

5. If this minister prefers to serve with someone, add that minister to the Serve With List. 

6. If another minister is able to fill in for this minister, add that minister to the Substitute List. 

7. Click Save. 

 
Paula thinks about the Serve With List again. But what if, for whatever reason, the parish doesn't want 

two ministers to serve together? 

 

Well, she's in luck – just like the Serve With List, there's a Do Not Serve With List. 

 

To add someone to a minister's Do Not Serve With List 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Ministry List. 

4. In the Do Not Serve With List grid, click the drop-down list and select a minister. 

5. Click Save. 

 

 Set a Minister's Preferences for Masses 

We mentioned earlier that Debbie likes to serve at the 9:00 AM Sunday mass. This is where Paula can 

set those. Once she adds ministries on a minister's record, she can determine their preferences for 

masses. 

 

To set a minister's mass preferences 

1. On the Information tab, click Ministers. 

2. Locate the minister's record. 

3. In the left navigation pane, click Mass Preferences. 

4. Each ministry the minister is involved in displays on a tab. On each tab, select the mass that the 

minister prefers related to that ministry. 
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5. Optionally, assign a different mass to the minister. This means the minister can serve this mass if 

their preferred mass isn't available. 

6. If the minister doesn't prefer a mass, insert it in the Least Preferred Masses grid. 

7. Click Save. 

 

 

 Now it's your turn 

Now that we've completed Steve's record, let's add another one. This time, it's the family minister, who 

happens to be Steve's wife. 

 

1. Add Estelle Parker Redmond as a minister using the following fields from Steve Redmond's 

record: 
 

 Last Name (since they're married) 

 Street Address (they live together) 

 First Phone Number (they have the same home phone number) 

 Away Periods (they're both going on the mission trip in December) 

 
2. Complete Estelle's record with the following information. She's the family minister and sings in 

the choir. She is not available to serve on the first week of each month because she helps at the 

homeless shelter. 
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 Action Plan 
 

Whew, that was a lot of information! Let's take a short break to review. So far, we talked about setting 

up options, adding masses, and adding minister records. 
 

Use the space below to write down: 
 

 A list of tasks you need to do to set up PDS for your parish. 

 

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________ 

 

 Questions you need to ask when you get back to the office, such as: 
 

"How does my parish determine which ministers are scheduled for each mass?" 

"What does the scheduling process need to know about how my parish's masses are assigned?" 

"What's the best way to find out when my ministers are available to serve?" 
 

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________ 
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 People you need to talk to and why. For example: 

Name    Steve Redmond__________________________   Title    Outreach minister  

o    Who can substitute for you when are away on a mission trip?____________________  

o    How many days per week can you serve? ____________________________________  

 

Name  ________________________________________  Title  __________________________  

o  ______________________________________________________________________  

o  ______________________________________________________________________  

 

Name  ________________________________________  Title  __________________________  

o  ______________________________________________________________________  

o  ______________________________________________________________________  

 

Name  ________________________________________  Title  __________________________  

o  ______________________________________________________________________  

o  ______________________________________________________________________  
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Unit 4:  Scheduling 
 

Ben stops by Paula's office to pick up his assignments for next week. Paula leaves PDS to go back to her 

spreadsheet world for a moment. She looks through her files and emails to find Ben's schedule. It will be 

nice to have everything in one place inside Ministry Scheduler. 

 

She prints it out and passes it to him. Before he leaves, Paula calls Ben back and prints another page. 

She hands him Ana's schedule and winks. He smiles and says he'll get it to Ana. 

 

By the end of this unit, you'll be able to: 

 Set up a schedule for one or more weeks 

 Automatically assign ministers to their selected ministries on the schedule 

 Assign ministers to a ministry on the schedule manually 

 Test how a schedule will look without affecting minister records 
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 Understand How Ministers are Assigned 

A schedule contains all the masses you added during a given date range. The scheduler must determine 

which ministers can serve each mass based on each minister's preferences that you set up earlier. 

 

Here's how the scheduling process works, in a nutshell: 

 

 
 

 
 

 
 

Sort the ministers by Last Served data 

 Last Served dates should not be later than the period you're scheduling. 

Create a list of minister with direct assignments 

 Ministers with direct assignments come before those with the oldest Last Served dates. 

 If the first minister in the list has a preferred mass, the Mass List is re-sorted so the preferred 

mass is the first possible mass to be assigned. 

Check all the minister records individually 

This step confirms that: 

 The mass isn't on a Cannot Serve day or week or during a minister's away period 

 The mass isn't one of the three least preferred and the mass type is permitted 

 The minster's class is included for the mass 

 A minister with the same family ID isn't already scheduled for another mass the same week 

 The minister serves for an available ministry at the mass 

 There is no violation of other scheduling rules involving consecutive weeks or odd/even weeks. 
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Paula feels a bit overwhelmed by the scheduling process, but she's happy to hear that she can schedule 

in test mode. That way, she can run a schedule without affecting any minister records. 

 

Let's see how to add a schedule, then we'll talk more about how you can test it to make sure it's what 

you expect to happen. 

 

 Add a Schedule and Assign Ministers 

Finally, the time has come. Paula's ready to try out this scheduling process. 

 

To add a schedule and assign ministers 

1. On the Information tab, click Schedules. 

2. Enter the date that the schedule should start on and the date it should end. 

3. Click Next >. 

4. If you're scheduling multiple weeks, select whether to schedule each week individually or all 

weeks at once. 

5. Select the week you want to schedule, and click Next >. 

6. The scheduler works to schedule ministers for the required assignments. The results display. 

7. Click Next >. 

8. If there are any unfilled positions on the schedule, right-click it to manually assign a minister, if 

needed. If you need to replace a minister, right-click the minister's name. 

9. When you're ready, click Save Schedule. 

10. Click Finish. 

 

Assign each minister 

 If the previous criteria are met, the minister is assigned the mass. 

 For each minister, the masses in the Preferred Mass list are tested in order. 

 If any one of the tests fails and the minister is flagged as adamant about these preferred 

masses, no other assignments are attempted for that minister. He/She is removed from 

the pool of ministers for the week. 

 Otherwise, the minister is not flagged as adamant about serving at his/her preferred 

masses, and the next mass on the list is tested. 

 This process continues until either the minister receives an assignment or all the available 

masses have been tested. 
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5. If you're scheduling multiple weeks, select whether to schedule each week individually or all 

weeks at once. 

6. For each week you want to schedule, select Blank Week Schedule on the right. 

7. Click Next >. 

8. The blank schedule displays. For each position column, right-click in the grid to assign a minister. 

9. When you're ready, click Save Schedule. 

10. Click Finish. 

 

 Test a Schedule 

As we've reviewed in previous units, many settings and options affect how ministers are assigned. 

 

Since she's still new to Ministry Scheduler, Paula wants to run a schedule without touching those 

settings so she can see what happens. And if she decides not to keep that schedule, the minister records 

and settings won't be disturbed. 

 

To test a schedule 

1. On the Information tab, click Schedules. 

2. Select the Schedule Test Mode check box at the bottom. 

3. Follow the rest of the steps for adding a schedule. 

 

If Paula is happy with the results of the test schedule, she can make it permanent. Once she does this, 

the scheduled assignments are applied to the minister records. 

 

To make a test schedule permanent 

1. On the Information tab, click Schedules. 

2. In the Scheduled Weeks window, select Show Test Schedules. 

3. Click Make Test Permanent. 

4. In the dialog box, select the test schedule(s) you want to make permanent. 

5. Click Change/OK. 

6. Confirm that you want to make the test schedule(s) permanent. 

7. Click Close. 

 



37 

 Assign a Minister Directly to a Specific Mass 

Clara Quinn stops by Paula's office after choir practice. She volunteers at least once a week, and she 

wants to know if she can help this week. Paula has already made the schedule but can always find room 

for one more. 

 

There may be times when Paula just needs to assign a specific minister to a specific mass without going 

through scheduling. For example, several volunteers can participate in certain masses. But Paula doesn't 

want them to take the primary minister assignments. 

 

The best thing to do in this case is to add each volunteer as a minister and select Do Not Schedule (like 

we talked about in Unit 3). Then, Paula can add direct assignments when she needs volunteers. 

 

To schedule a direct assignment 

1. Find the minister's record. 

2. In the left navigation pane, click Assignment Options. 

3. In the Direct Assignments section at the bottom, click Insert. 

4. In the grid, enter the date of the mass, the mass name, the ministry name, and any notes you 

need to know. 

5. Click Save. 

6. If you want to schedule a minister's direct assignments even if you selected Do Not Schedule, 

select Only Schedule Direct Assignments. 

7. To overwrite any scheduling restrictions for a minister's direct assignments, select Direct 

Assignments Overwrite the Scheduling Restrictions. If selected, the scheduler disregards the 

number of max assignments per week and assigns a minister to the same mass and same date. 

 

 

 Now it's your turn 

1. Create a test schedule for the first 2 weeks of next month using the example masses we've 

added so far. 

 

2. Make the test schedule a permanent schedule. 
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Unit 5:  Communicating with Ministers 
 

Communication hasn't always been the best at Saint Mary's. Back when Jim was in charge, he had a hard 

time keeping that "door of communication" open. It's not that he wasn't friendly – he was just 

overloaded with all the manual work of scheduling. 

 

When Paula took over, she made it a top priority to listen to ministers' needs and keep them informed 

of the activities at Saint Mary's. 

 

At the end of this unit, you'll know how to: 

 Create a letter to send to ministers via mail 

 Construct an email to send to ministers 

 Set up a text message to send to ministers 

 Allow ministers to view and change their scheduled assignments online 

 Approve or deny online changes to minister assignments 
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 Send Letters to Ministers 

Paula usually keeps in contact with her ministers via email, but every now and then, it's important to 

send an actual paper letter in the mail. 

 

For example, she can send any of the following predefined letters: 
 

 Thank You for Volunteering Letter – Thank ministers for being willing to volunteer. 

 Minister Away Period Confirmation Letter – Confirm a minister's scheduled away time. 

 Letter and Minister Assignments – List of assignments for specified dates. 

 Letter to Minister – Write your own message to ministers. 

 

Then there are some letters you can use to gather or confirm minister information: 
 

 Text Message Permission Form – Collect cell phone information before sending texts from PDS. 

 Minister Online Information Letter – Let ministers know log in information for the online app. 

 

And you can always create your own letter from scratch. We'll go over reports in Unit 7. 

 

 Send Emails and Texts 

Saint Mary's is pretty tech-savvy. Paula works hard to get her ministers involved in tech-forward 

thinking. Most ministers read emails, so Paula's glad to know she can send them within PDS. 

 

The music minister, Manny – who does everything on his iPhone – always asks Paula to text him with his 

weekly assignments. Before, it was a pain trying to type all that information on her phone. Now she can 

send it from PDS! 

 

Anything that can be sent as a printed letter can be emailed. At the end of the report wizard (which we'll 

talk about later), you have several options on how to send the emails. 

 

 
Figure 5-a. Email report options 
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You can: 
 

 Email the Letter If: Preferred is Checked – Sends to ministers who have the Pref. check box 

selected in the Contact Information window. 

 Email the Letter If: Has an Email Addr. – Sends to ministers who have an email address entered 

on their record. 

 

If you select either email options, you can also send the letter to multiple addresses. 
 

 Send to Multiple Emails – Sends to all the email addresses in the minister's Contact Information 

window. 

 

We'll talk more about the rest of the steps involved with sending letters in Unit 7. 

 

 Allow Ministers to View and Change Assignments Online 

Several ministers have told Paula that they'd love to have an online schedule. Manny has mentioned this 

numerous times. Finally, Paula can set this up for them using the PDS Minister Web App. 

 
Turn On App Options in PDS 

First, Paula needs to turn on the app options. If she decides that the web app is not right for Saint Mary's 

or the ministers, she can always turn the options off so they don't display in Ministry Scheduler. 

 

To turn on options for the minister app 

1. On the File menu, click Setup > Initial Setup. 

2. Select Minister Online Access. 

3. Click Save/OK, then Close. 

 
Set Up Online Login Credentials for Ministers 

Paula knows some of her, we'll say "less tech-savvy" ministers won't use this, but she sets them up with 

logins, just in case. Who knows – maybe they'll get with the times! 

 

After all, if Father Philip (who still uses a paper planner to keep up with his schedule) can do it, anyone 

can! Plus, it's a web app, which means ministers can log in from their computer, tablet, or phone. 

 

And they all at least know how to use a computer. 
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Because the app allows ministers to make changes to their assignments, each one needs a log in. 

 

To set up web app login credentials for a minister 

1. Find the minister's record. 

2. In the navigation pane on the left, click Contact Information. 

3. In the Minister Online Information section at the bottom-right, click Set Up. 

TIP: If you don't see Minister Online Information, you need to turn on the app options. 

4. The user name defaults to the first email address listed in the minister's record. If you change it 

in this dialog box, the email address on the record is updated. 

5. The password defaults to the minister's first name, the initial of their last name, and their PDS ID 

number. You can change this if needed. 

6. Click Save, then Close. 

 

After you set up minister logins, you can send the letter we talked about earlier (under Minister Letter 

Reports). That way, your ministers know how and where to log in. 

 

 

Upload Ministers and Assignments for Online View 

Once all the minister logins are set up and the schedules are finished, Paula can send all of that to the 

app. This process uploads schedule information from today's date forward. 

 

To upload assignments to the web app 

1. On the File menu, click Data Synchronization > Upload Ministers and Schedule Assignments. 

TIP: If you don't see this process, you need to turn on the app options. 

2. Read about how the process works, then click Next. 

3. If you want to receive a notice when ministers make changes, enter an email address or use one 

from another area of Ministry Scheduler. 

4. When you're ready, click Upload. 

5. To print a list of the information that was uploaded, click Yes. Click No to exit the process. 
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 Now it's your turn 

Paula prints out the list and realizes she's missing the hospitality minister, Gabrielle Fulton. She adds 

Gabby's record, sets up her login, and emails her the Minister Online Information Letter. The next day, 

Gabby calls and says she can't log in. She gets the message "The user name or password is invalid". 

 

1. What did Paula forget to do to get Gabby's information on the app? 

 

______________________________________________________________________________

______________________________________________________________________________ 

 

A few weeks later, the prayer minister, Debbie, drops by Paula's office and gives her new email address. 

Her account was hacked, so she needs to close it down. She is only going to use her new one going 

forward. 

 

2. What 3 things does Paula need to do to make sure Debbie's email address is updated in PDS and 

on the app? 

 

a. __________________________________________ 

b. __________________________________________ 

c. __________________________________________ 

 

Using the Minister Web App 

Paula is sure her ministers will have questions, so she decides to set up a quick meeting to go over how 

to use the web app. 

 

After setting up credentials and uploading data, ministers can go to minister.parish.mobi on their mobile 

device or computer. After they log in, they can view and change their assignments. 

 

Paula adds next week's schedule and uploads the information to the app. The next day, Gabby declines 

her assigned position as a lector. Since Estelle is also a lector, she sees that open assignment on her app, 

and she takes it. 

 

Since she chose to be notified (during the upload), Paula gets an email. She can then accept or reject the 

changes that Gabby and Estelle made. Otherwise, if she did not want a notice, Paula would see the 

changes next time she ran the upload process.  

http://minister.parish.mobi/
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 Action Plan 
 

We've gone over a lot so far! Since our last stopping point, we've learned how to set up mass schedules, 

assign ministers to ministries, and communicate with ministers in various ways. 
 

Take this time to write down anything you need to before we continue on to the next unit, such as: 
 

 What additional tasks you need to do when training is finished. 

 Tips that you learned along the way. 

 Areas or situations you still have questions about. 
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Unit 6:  Viewing & Printing Information 
 

Paula loves that she now has all of her information in PDS – one location instead of a bunch of separate 

spreadsheets. Now, let's see how she can view that information in the best way for her needs. 

 

By the end of this unit, you'll be able to: 

 View and print weekly schedules with minister assignments 

 Publish schedules to your website for ministers to view 

 Export your schedules to an Excel file 
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 View a List of All Your Masses, Ministers, or Schedules 

Paula is still getting used to the idea of records in PDS. She has worked in spreadsheets for so long, and 

she misses seeing all the information together in one place. 

 

Then, like magic, as she clicks through, Paula discovers the listing screen. It includes all the minister data 

in columns, just like her spreadsheet! 

 

 
Figure 6-a. The Ministers Listing Screen 

 
Curious, she clicks Customize View at the bottom. Paula can pick any fields from the records to view in 

her list. This will come in handy when Father Philip asks for specific information on all the ministers. 

Paula won't have to click through every record to find the answers. And she can even print it for him 

from this window. 

 

There are listing screens for ministers, masses, and schedules. In the navigation pane of each section, 

click Listing Screen. 

 
Here are a few helpful tips about listing screens: 
 

 Inactive records and masses appear in red text. 
 

 Old masses that have passed appear in blue. 
 

 An ellipsis (…) at the end of an entry means you are seeing incomplete information. Hover over 

the ellipsis to view the complete information. 
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 Now it's your turn 

1. In the Ministers listing screen, reorder the columns so the Street Address and City columns 

display immediately after the Minister Name column. 
 

2. Add all minister email addresses and phone numbers to the listing screen. 
 

3. Zoom the listing screen so it takes up the entire screen. Restore the window to its original size. 
 

4. The width of a column can't be smaller than the column's __________________. 
 

5. Resize the Minister Email List column to 25. 
 

6. Father Philip comes by Paula's office, huffing and puffing. What is it today, Paula wonders. He 

wants to know which ministers can substitute for daily masses, and he needs it right now. How 

can Paula get this information for him? 
 

a. Go to the minister ___________________  _______________. 
 

b. Click ____________________  ______________. 
 

c. Expand Minister > _____________________, and select the _______________ field. 
 

d. Use the right _________________  __________________ to move the selected field to the 

"Fields you want to view" section. 
 

e. Use the _____________ arrow button to remove any unnecessary fields from view. 
 

f. Click ___________________. 
 

 Print & Export Schedules 

In Unit 4, we covered how to view the scheduled weeks and the details of a week. Now let's find out 

how to print those in an easy-to-read format and export them to other programs. 

 

Print Scheduled Weeks 

Some people (Paula's looking at you, Father Philip) still like a printed schedule to put on the wall. 

 

To print a schedule 

1. On the Reports tab, click Schedule Reports. 

2. Expand Listing Reports. 

3. Select a report based on your needs. Click the thumbnail image on the right to see what the 

report looks like with sample data. 

 

We'll talk about the rest of the steps for printing reports in the next unit. 
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Export Schedules to an Excel File 

Father Henry, who's a bit more up-to-date with technology, wants to see the scheduled assignments in 

an Excel spreadsheet. This way, he can pull it up whenever he needs it. 

 

To export a schedule to Excel 

1. On the Reports tab, click Schedule Reports. 

2. Expand Export Reports. 

3. Select a report based on your needs. 

 

We'll go over the rest of the steps for exporting a report in the next unit. 

 

 Display Schedules on Your Website 

The web app we discussed earlier shows each minister his or her assignments. But what if ministers (or 

other staff) need to see everyone's assignments? Paula can publish a schedule to Saint Mary's website. 

 

To create web schedules 

1. On the Reports tab, click Schedule Reports. 

2. Expand Web Page Reports. 

3. Select a report based on your needs. 

 

This is for viewing only. No one can make changes to online schedules. 
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Unit 7:  Working with Reports and Letters 
 

Paula relies on reports to keep her informed on everything happening at Saint Mary's. Until now, she 

created them in a word processor and had to fill in all the information she wanted by looking at her 

spreadsheets. 

 

At the end of this unit, you'll know how to: 

 Select, preview, and print a predefined report 

 Build a custom report with the information you want to see 

 Export data to a file you can use in a word processor, a spreadsheet, or another program 
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 Print a Predefined Report 

Fortunately, PDS has numerous reports Paula can run with any or all of the minister and mass data she 

wants. And if none of the predefined reports fit her needs, she can modify a similar report or create a 

new one. 

 
Pick Your Report 

Paula can run reports with information on her ministers, masses, and schedules. There are different 

types of reports for each of these areas. 

 

 If Paula wants to see a list of information, she can run a listing report. These reports show 

information from PDS in a grid format, so you can print things like a list of contact information 

for ministers, a list of preferred masses for each minister, a list of your schedules, and so on. 
 

 To send a letter to ministers, Paula can run a letter report. And if she's mailing the letters (or any 

other report), she can print labels and envelopes. 
 

 Ministers have another group of reports called Data Export/Quick Communication. These 

reports help you gather the information you need to send emails and text messages to 

ministers. 
 

 Masses and schedules have a group called Export Reports. Use these to send information to an 

Excel file. 
 

 You can use a Web Page Report to put your schedule on your church's website. 

 

 

And if you don't see what you need, you can create your own! We'll talk about those in a moment. 

There are lots more. Look through these groups to become familiar with all the different reports. 

 

To pick your report 

1. On the Reports tab, click the type of report you want. 

2. In the list, expand the report group you need. 

3. Click a report, and you'll see a preview of it (with sample data) on the right. 

4. If that's the report you want, click Next to continue through the report wizard. 

 
Let's go over some things you may need to do before printing the report. These are steps in the report 

wizard. 
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Edit the Overview 

All reports have an overview window that lists the report name and description, along with some layout 

and selection options you may have previously set. 

 

Select Printer Settings 

The next window in the report wizard is where you select your printer and page settings. Ask your 

network administrator if you have problems with printer settings. 

 

Modify the Layout 

Different reports have different layout windows. We'll look at these options later. 

 

Select Which Records to Print 

Paula picks the Mass Ministry Sign-Up Sheet report so the ministers can choose where they want to 

serve in the Christmas Midnight Mass this year. When she previews the report, she notices there are 

sign-up sheets for all the masses she has added. 

 

Instead of printing all the masses and wasting paper, Paula can use the selection options to print the 

report for just the Christmas Midnight Mass. 

 

The Selection window only displays options that are relevant to the report you selected. 

 

Preview and Print 

Okay, Paula has set all of her settings and selected all of her selections. It must be time to print this 

thing. But first, let's make sure we know what it's going to look like.  

 

To preview and print your report 

1. After making your selections, click Preview at the bottom. 

2. Check your report.  

3. To go back and change a setting, click Back. 

4. Once you're happy with how the report looks, click Print. 
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 Build Your Own Reports 

After printing the sign-up sheet, Paula looks for a report that lists the ministers, their ministries, and 

their email addresses. She can't quite find a report that fully covers this. 

 
Copy and Modify an Existing Report 

After searching the predefined reports, she finds that the Minister Ministry List is similar to what she 

wants, but she needs to print each minister's email address as well. 

 

Paula can select the predefined report that almost meets her needs, copy it, then modify it to exactly 

meet her needs. The reports that you copy and modify in PDS are called Easy Reports. 

 

To copy and modify an existing report 

1. Locate and select the report you want to copy. 

2. At the bottom, click Copy. A copy is added to the Easy Reports section under your report type. 

3. With the copied report selected, click Next. 

4. Edit the name and description, if needed. 

5. Click Next, and follow the Reports wizard to define and customize your report. 

 

To add the field she wants on the Minister Ministry List, Paula clicks Modify the List of Fields to Print on 

the Listing Layout window. 

 

If you can't locate a report similar to what you need, add a new report. 

 
Add a Custom Report 

A tight fist thumps hastily on Paula's door. She'd bet money that it's Father Philip. Most people 

understand a closed door means no interruptions. It's not often Paula closes her door, but when she 

does, Father Philip is guaranteed to need something from her. Another knock-knock-knock shakes Paula 

from her thoughts. She rolls her chair over and turns the knob. Oh what a surprise, it's Father Philip. 

 

He wants a report that lists each minister, the ministries they serve, and the number of assignments 

they currently have. Then, below that, he wants a list of the ministers and volunteers who can substitute 

for the minister as well as their ministries.  

 

Since it's a bit complicated, Paula decides to create a custom report. Before she adds it, she outlines the 

information Father Philip needs and makes notes about the formatting she wants. This way, she has 

something to work from when creating the report. 
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To add a custom report 

1. On the Reports tab, click the button for the type of report you want. For example, if you're 

adding a letter to your ministers, click Minister Reports. 

2. Click Add at the bottom. The Add Report dialog box displays. 

3. On the Simple Reports tab, click the type of report you want to create. A new report called "New 

<type> Report" is added to Easy Reports section of the group you selected.  

 For some reports (list and export reports, for example), the List of Fields to Print dialog box 

displays, and you can define the fields you want to include in your report. 

 For other reports (letter, label, and envelope, for example), the Editing window displays, and 

you can define the content of your correspondence. 

4. Edit the name and description of the report. Select a report owner, and designate report access. 

5. Save your changes, and continue the report wizard to print your report. 

 

When adding a new report or copying an existing report, you have ownership of that report and can 

specify if only you and the administrator have access, if you want to share it but not allow anyone to 

modify it, or if everyone should be able to print and modify it. 

 

Share Custom Reports 

You can save your custom reports to a reusable storage device or hard drive to protect them from loss. 

You can also install your reports on other computers in your office or share them with other 

organizations that use PDS. 

 

To save a custom report outside of PDS 

1. In the Select Report window, select the report you created. 

2. Click Save as Custom Report. 

3. In the Save Custom Report Files dialog box, find the location where you want to save the report.  

4. Enter a file name, and click Save. 

 

After saving your report, you can send the file to a coworker, and they can add it into PDS using the 

Custom Report option. 

 

To add an existing custom report into PDS 

1. In the Select Report window, click Add. 

2. Click Custom Report. 

3. Locate the custom report file (.cr) you want to add, and click Open. The report displays in the 

Easy Reports section. 
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 Export Data to a File 

Paula is feeling good about Ministry Scheduler, but it may be a while before she can let completely go of 

her precious spreadsheets. That's all she's had up to this point, and they hold so much information – she 

can't just toss it all! 
 

Luckily, Paula can export information to a word processor, a spreadsheet, Microsoft® Outlook®, 

Calendar Creator, or another program using export reports. Export reports are similar to list reports, but 

the data is sent to a file rather than a printer. 

 

To define an export report  

1. In the Select Report window, select the report category where you want to add the export. 

2. Click Add > Export. The List of Fields to Print dialog box displays. 

3. Select the field names you want to include and click the right arrow button to move them to 

Fields you want to print. Click Save/OK. 

4. In the Overview window, click Edit to enter the report's name and description. If you have 

access to designate reports, select a report owner and report access. Click Next. 

5. In the Export Properties window, click File Format to select one of the following file formats: 

 Comma Separated Values (CSV) — Creates a text file with data items separated by commas. 

This format includes headings. 

 XML — Creates an Extensible Markup Language file for sharing data on the web. 

 Line/Form Delimited — Creates a file with a line feed at the end of each field and a form 

feed at the end of each record. 

 Line/Form Delimited With Headings — Creates a file with column headings, a line feed at 

the end of each field, and a form feed at the end of each record. 

 Tab Delimited — Creates a text file with data items separated by tabs. 

 Tab Delimited With Headings — Creates a text file with column headings and data items 

separated by tabs. 

 Fixed Width — Creates a file that always prints the same number of characters for a field. 

So, if you print Org Name (75 characters), Contact Name (30 characters), and ZIP Code (15 

characters), the file always contain exactly that number of characters for those fields. If it 

has more than these, it's clipped. If it's shorter, the length is filled with spaces. 

 CSV Without Headings — Creates a text file with data items separated by commas, but does 

not include headings. 
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6. Enter the name of the file you're creating. 

7. To alter the list of selected fields, click Modify the List of Fields to Export. 

8. Click Next. 

9. Make any additional selections you want. Click Build to export the data to a file. 

 

 Now it's your turn 

Paula found out that her friend Nancy at Sacred Heart Church also uses PDS Ministry Scheduler. Nancy 

tells her about a cool report she created. Paula would love to print this report for her ministers. 

 

1. How can Nancy save her report to share with Paula?  

______________________________________________________________________________

______________________________________________________________________________ 

2. How can Paula add the saved report into her Ministry Scheduler report list?  

______________________________________________________________________________

______________________________________________________________________________ 
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 Action Plan 
 

Quick! Before you lose all those great ideas floating around in your head, jot them down here. 

Write down any details you need to think about or things to do when you get back to your parish. 
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That's a Wrap! 
 

We reviewed the basic functions of Ministry Scheduler. Soon enough, with practice, you'll be a pro. 

 

 
 

There's still more that you'll discover on your own, and we'll be here to help you through that. There are 

several ways to get help with Ministry Scheduler. 

 

 Review the Ministry Scheduler Help Guide at http://wiki.acstechnologies.com/display/PDSMS. 

 Check out training opportunities at www.acstechnologies.com/products/pds/services/training. 

 Call the PDS Support team at 1-877-737-4457. 

 Consider attending the ACS Technologies Ideas to Impact Conference. You'll find much more 

than just classes on PDS products. There are strategical classes for enhancing your ministry, and 

you'll get to network with other users from all over the country. See http://ideastoimpact.com. 

 

  

http://wiki.acstechnologies.com/display/PDSMS
http://www.acstechnologies.com/products/pds/services/training
http://ideastoimpact.com/
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Additional Reference Information 
 

During the limited time of this training class, we couldn't possibly cover every feature and option in 

Ministry Scheduler. This section includes information that you can refer to when needed. 

 

 Security 

Father Philip is always asking Paula for information that's listed in PDS. To alleviate the frequent phone 

calls and visits from him, she can add Father Philip as a Ministry Scheduler user. This way, he can log in 

to PDS and view the information he needs. 

 

And, since Father Philip doesn't need the ability to schedule ministers, Paula can set his rights to exclude 

the scheduling section of Ministry Scheduler. He only sees the sections Paula gives him permission to 

view. It's not that she doesn't trust him, but Paula is protective over her database and wants to keep it 

as clean as possible. 

 

Using one of the security options in PDS is the best way to keep your data safe and clean. 

 

Here’s some important information you should know about security: 

 

 When Ministry Scheduler is first installed, anyone can view and change data. While it's optional, 

we recommend that you set up user names and passwords to prevent unwanted changes. 

 If you log in and leave your desk without exiting PDS, your computer doesn’t know you’re not 

there. Anyone at your desk can access your PDS information. 

 When someone leaves your organization, do not assign that person’s name and login to the 

person taking his or her place. Delete the old user, and add the new one. 

 Who is in charge of security in PDS? If something happens to that person, do you have another 

way to access the security options and add, edit, and delete users? 
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To add a user and assign rights 

1. On the Administration tab, click Users & Passwords. 

2. At the top, click Add User. 

3. Enter a user name for the person. This doesn't have to be their full name or real name. For 

example, Deborah might want her user name to be "Debbie". This is not case-sensitive. 

4. If you require passwords, enter one for this person. This can be up to 10 letters and/or numbers 

and is case-sensitive. 

5. Select whether this person is a security administrator. Admins have full access to all sections of 

Ministry Scheduler and can make changes to all data, including users and passwords. 

6. If needed, enter a phone number. 

7. In the grid, review each program area. The blue rows are main sections, and the white rows are 

specific windows or processes. If needed, click Print Worksheet on the left to view all of these. 

8. For each program area, select an access option: 

 No Access – User cannot view any windows, processes, or reports. 

 View Only Access – User can view windows and records, and print reports, but can't add 

or delete information. 

 All Access – User can view windows, processes, and reports, and can add, edit, and 

delete information. 

9. Click Save at the top. 

 

 

Make sure at least one user you added, ideally the system administrator, has full access to the program 

before setting the security method. 

 

To enable a security method 

1. On the Administration tab, click Users & Passwords. 

2. In the left navigation pane, click Set Security Method. 

3. Select the security method you want. If you select to detect Windows or OnDemand 

authentication, the user name in PDS must match the name the user logs in to Windows or 

OnDemand with. 

4. Click Save/OK. 
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 Back Up Your Data 

Guarding against loss due to a natural disaster or database corruption is important. 

 

OnDemand Backups 

If you use OnDemand, your data is backed up automatically each night and stored on the server, so you 

don't need to schedule automatic backups. 

 

Automatic Backups 

Otherwise, you can set PDS Ministry Scheduler to perform backups automatically on selected days. 

 

Before you set up automatic backups, make sure that: 
 

 PDS is installed on the computer or server that stores the data. 

 The computer or server is on at the time when the automatic backup is scheduled to run. 

 All other PDS users are logged out. 

 You entered your email address in the License Information window. If there's a problem 

with the backup, you'll get an email. 

 
To set up automatic backup options 

1. On the File menu, click Backup/Restore > Backup Options. 

2. Select the day(s) you want to run an automatic backup of your data. 

3. Enter the path for the location of your internal archive folder where your backups will live. 

4. Select a level of protection for your data. 

5. Click Close. 

 

Paula sets her automatic update to run daily every week. When she starts PDS, she knows her data is 

captured, and she can restore her data to this point in time if she makes any big mistakes. However, 

she'd also like to back up her data before she makes major changes. She can run a manual backup at any 

time. 

 

Manual Backups 

Before you manually back up your data, make sure: 
 

 You have at least 0.5 MB of free space on your backup media to complete the backup. 

 You disable your computer's Hibernate, Sleep, or Stand By options. 

 All PDS users are logged out. 

 Your backup media is preformatted. 
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To back up your data manually 

1. On the File menu, click Backup/Restore > Backup Data. 

2. Enter a backup reason. This prints on the report and displays if you need to restore the data. 

3. Select a backup method. You can: 

 Back up to a selected drive such as a floppy disk. 

 Back up to a specific folder such as the hard drive, CD-ROM, or any other drive. 

 Back up to an Internet FTP Server send the data to a website (File Transfer Protocol). 

4. Select a backup location, or enter your FTP Server information. 

5. Click Start Backup. 
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Answers 
 

We'd hate to give you a bunch of questions and not give you the answers! Here are the answers to the 

questions in each section that pertained to Ministry Scheduler. 

 

Unit 1 

Set Up Options Used for Scheduling (Page 9) 

1. Ana is scheduled because this is a special mass. Paula needs to enforce the Cannot Serve Days 

option for Special Masses under File > Setup > Scheduling Options. 

 

Add and Combine Keywords (Page 12) 

1. Ana's record now shows "Work Phone" as the phone number description. 

2. Ben's record now shows "Work Phone" as the phone number description. 

3. Nothing shows in the phone number description on Ana and Ben's records. 

 

Unit 2 

Add a Mass (Page 18) 

1. When adding a mass, you need the type (permanent, special, daily), name, time, the day(s) or 

date the mass occurs, the ministries required for the mass, and the number of ministers needed. 

2. Click Add Mass. For mass type, select Special. For name, enter "Christmas Midnight Mass". For 

time, enter "12:00 AM". In the Special Type section, enter 12/25 of this year. In the Mass 

Ministry grid, click Insert and enter "Altar Server" (add it to the keyword list if it isn't already 

there). Press Tab and enter "4". Click Insert and enter "Eucharist Minister". Press Tab and enter 

"2". Click Insert and enter "Lector". Press Tab and enter "2". Click Save. 

The finished record looks like this: 
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Unit 3 

Add a Minister (Page 21) 

1. To add Steve Redmond as a minister, click Add Minister. Click Add New Minister. For street 

address, enter "455 Pleasant Way". For city/state, enter "Florence, SC". For ZIP/postal, enter 

"29501". For phone number, enter "843 555 4324", and select the description Home. Press Tab. 

Enter "843 555 7897", and select the description Cell. For email address, enter 

"s.redmond@parishdata.com". Click Save. 

 

Determine How Ministers Are Scheduled (Page 24) 

1. Select the Do Not Schedule option on Steve's record 

2. Mark Evan as inactive 

3. Do Not Schedule Debbie 

 

Set Dates When Ministers Can and Cannot Serve (Page 27) 

1. Paula can set the dates in the Away Periods grid of the Date Restrictions window on Steve's 

record. 

2. To add Steve's mission trip dates, locate his minister record. In the navigation pane, click Date 

Restrictions. In the Away Periods grid, enter 12/05/2016 in the From field, enter 12/10/2016 in 

the To field, and select Mission Trip from the Reason Away drop-down list. Click Save. 

 

Set a Minister's Preferences for Masses (Page 30) 

1. Before copying the minister, on the File menu, click Setup > Minister Data to Copy. Select Last 

Name, Street Address, First Phone Number, and Away Periods. Click Save/OK, then Close. On 

the Information tab, click Ministers. To add Estelle Parker Redmond as a minister, click Add 

Minister. In the list, locate and select Steve Redmond. Click Use This Minister Info. Click Save. 

2. On the Ministry List window, insert Family and Choir into the grid. On the Date Restrictions 

window, select First under Cannot Serve Weeks. 

 

Unit 4 

Assign a Minister Directly to a Specific Mass (Page 37) 

1. To create a test schedule, click Add Schedule. Enter the dates for the next two weeks or click-

and-drag the next two weeks on the calendar. Select the check box to schedule in test mode. 
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Click Next. Select the automatic scheduling option, and click Next >. It's okay if there are 

incomplete assignments. Click Next >. Click Save Schedule. Click Finish. 

2. To make the test schedule permanent, click Scheduled Weeks in the navigation pane. Make sure 

the Show Test Schedules check box is selected. Click Make Test Permanent. Select the weeks 

you added, and click Change/OK. When prompted, click Yes to continue. Click Close. In the 

Scheduled Weeks window, clear the Show Test Schedules check box, and you'll see the weeks 

you made permanent. 

 
Unit 5 

Allow Ministers to View and Change Assignments Online (Page 42) 

1. Paula set up Gabby's login and let Gabby know her credentials, but she forgot to upload the new 

information to the app. Paula needs to go to File > Data Synchronization > Upload Ministers and 

Schedule Assignments, and upload Gabby's login information. 

2. a.  On Debbie's minister record, delete the old email address.  

b.  Add the new email address. 

c.  Under Minister Online Information, click Set Up and click Reset. (Then let Debbie know her 

new credentials.) 

 
Unit 6 

View All Your Masses, Ministers, or Schedules in a List (Page 46) 

1. Click Customize View. In the Fields you want to view list, click Minister Street Address Line 1 

and click the up arrow button until the field is under Minister Orig Name. Click Minister Street 

City and click the up arrow button until the field is under Minister Street Address Line 1. Click 

Save/OK.    OR    On the listing screen, click-and-drag each column to the desired location. 

2. Click Customize View. In the Fields available to view list, expand Minister - Detail, and click 

Email List. Click the right arrow button to add the field to the Fields you want to view list. In the 

Fields available to view list, click Phone List, and click the right arrow button. Click Save/OK. 

3. On the listing screen, click Zoom. To restore the window, click Zoom again or click the X in the 

top-right corner. 

4. The width of a column can't be smaller than the column's ___heading___. 

5. To resize a column's width, click Customize View. In the Fields you want to view list, select 

Minister Email List. In Properties of the selected field, enter "25" for width. Click Save/OK. 
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6. a. Go to the minister ___listing___  ___screen___. 

b. Click ___Customize___  ___View___. 

c. Expand Minister > ___Substitute___, and select the ___Name___ field. 

d. Use the right ___arrow___  ___button___ to move the selected field to the "Fields you want 

to view" section. 

e. Use the ___left___ arrow button to remove any unnecessary fields from view. 

f. Click ___Save/OK___. 

 

Unit 7 

Export Data to a File (Page 54) 

1. To save her report to share with Paula, Nancy needs to select her report in the Report list and 

click Save as Custom Report. In the dialog box, she can save the report to her desktop. From 

there, she can send it to Paula via email or on a flash drive. 

2. To add the saved report into her program, Paula needs to save Nancy's report on her computer. 

Then in Ministry Scheduler, she can click Add in the Reports list, and choose Custom Report. 

Once she selects Nancy's report from the location where she saved it, she clicks Open, and the 

report shows up in her Easy Reports list. 

 

 


